Fritzbox 7590 AX, Glasfaser keine Internetverbindung

  • Ich nutze Tailscale VPN um aus jedweden externen Netz (IPv4 oder IPv6) auf meine IoT-Geräte (ebenfalls egal ob IPv4 oder IPv6) im Heimnetz zu zugreifen. Funktioniert auf NAS, Kameras, Sensoren, Sonoff-WLAN-Schalter, etc. Ist von extern, wie wenn man im Heimnetz wäre.

    Ich vermisse so eine externe IPv4 nicht.

    • Offizieller Beitrag

    Es gibt ganz verschiedene Anforderungen an einen Internetanschluss, und für eine ganze Reihe gar nicht so seltener Anforderungen ist öffentliche Erreichbarkeit über IPv4 zwingend, ohne dass der Kunde daran irgendetwas ändern könnte. Im Moment muss man bei der Deutschen Glasfaser dafür Klimmzüge machen, die unerfahrene Netzwerker überfordern.


    Die große Klasse der Leute, die nur selbst auf ihr Heimnetz zugreifen wollen, wäre bedient, wenn AVM endlich ein vernünftiges IPv6-taugliches VPN in die Fritzboxen integrieren würde. Keine Eile, lasst euch Zeit. IPv4 ist bei RIPE erst seit drei Jahren komplett ausverkauft.


    Aber die Bereitstellung von Gameservern z.B. wird noch lange öffentliche IPv4 Adressen benötigen, und da ist es mit TCP Portmappern nicht getan. Die zusätzliche Latenz einer Tunnellösung ist diesem Anwendungsfall auch eher abträglich.


    Mir personlich wäre eine IPv4 Adresse auf dem Anschluss keinen nennenswerten Aufpreis wert. ICH kann das selbst regeln. Aber ich habe volles Verständnis für alle, die sich den Aufwand nicht machen und einfach wieder DSL buchen, bis sich das Problem von selbst löst oder die DG von ihrem hohen Ross herunterkommt. Ich hoffe ja immer noch, dass die Deutsche Glasfaser endlich andere Provider findet, die über die Glasfaser ihre Dienste anbieten.

  • Ich versuche den Port 28967 freizugeben über IPv6. Leider mag das nicht gelingen. Es wird zwar die richtige IPv6-Adresse in der Fritzbox angezeigt aber in dem ipconfig /all ist noch eine Temporäre IPv6-Adresse, mit der ich im Internet auch erreichbar bin. Wie kriege ich die Freigabe auf diese Temp-Adresse umgeleitet? Hat das einer mal erfolgreich geschafft?

  • Das will man doch gar nicht, denn die ist ja in kurzer Zeit wieder weg. Freigaben macht man immer auf die statischen Adressen, sonst muss man ja andauernd die Freigaben anpassen.

    Aber wo stelle ich dann die Umleitung von der Temp-Adresse auf die statische? Die Anwendungen begreifen das doch nicht selbständig?

  • Doch, wenn die Anwendung nicht komplett meschugge implementiert ist, dann lauscht sie auf allen verfügbaren IPv6 Adressen. Und auf den IPv4 Adressen wahrscheinlich auch.


    Es geht ja immer noch im Server Anwendungen, die auf von außen reinkommende Client Anfragen warten. Das hat nichts mit Anwendungen zu tun, die auf dem Server laufen und ihrerseits die Verbindung ins Internet aufbauen. Letztere können die temporäre Adresse nutzen. Für erstere nutzt man immer die statischen Adressen.

  • Die Auswahl der IPv6 Adresse, die für eine Verbindung genutzt wird, ist eine Wissenschaft für sich, aber normalerweise funktioniert das automatisch, wenn die richtigen Adressen existieren. Ausgehend werden meist temporäre Adressen bevorzugt, aber ankommend binden Programme normalerweise an alle Adressen und Interfaces. Dann spielt es keine Rolle, auf welcher Adresse eine Verbindung ankommt.


    In der Fritzbox solltest du deshalb eine möglichst statische Adresse freigeben. Um Änderungen im Präfix kümmert sich die Fritzbox, aber es gibt keinen Automatismus, wie die Fritzbox dynamische oder semi-statische "Interface-Identifier" (also die rechte Hälfte der Adresse) nachführt. Wenn sich der Interface Identifier ändert, musst du die Freigabe von Hand anpassen.

  • Wobei dieser Anschluss doch gar keiner mit "kundeneigenem Router" war, sondern die VLAN ID 360 für erfolgreichen Internetzugang eingegeben werden musste?


    Wen dem so ist, müsste für die Telefoniefunktionalität die VLAN-ID 330 in dem entsprechenden Menü der FB angegeben werden, so wie hier in Punkt 5 beschrieben:

    5 VLAN-ID für Internettelefonie eintragen -

    Internetrufnummern in FRITZ!Box einrichten | FRITZ!Box 7590
    Sie wollen in der FRITZ!Box Ihre Rufnummern einrichten, um über das Internet zu telefonieren? ✓ Mit dieser Anleitung geht das ganz einfach.
    avm.de

  • Ach so, für gemietete Router wird die Telefonie ja eigentlich fernkonfiguriert. Für kundeneigene Router ist es so, dass die SIP-Usernamen und Telefonnummern im Kundenportal stehen und die SIP-Passwörter per Brief kommen. Man kann die Daten aber auch beim Support erfragen.

  • Wobei dieser Anschluss doch gar keiner mit "kundeneigenem Router" war, sondern die VLAN ID 360 für erfolgreichen Internetzugang eingegeben werden musste?


    Wen dem so ist, müsste für die Telefoniefunktionalität die VLAN-ID 330 in dem entsprechenden Menü der FB angegeben werden, so wie hier in Punkt 5 beschrieben:

    5 VLAN-ID für Internettelefonie eintragen -

    https://avm.de/service/wissens…-in-FRITZ-Box-einrichten/

    Genau, da wurde VLAN ID 360 eingegeben.


    Welche VLAN ID hätte ich bei einem kundeneigenen Router eingegeben? Oder gar keine? Unter welchem Anschluss laufe ich, wenn es kein DG und kein kundeneignener Router ist?


    Aber auch für die VLAN ID 330 brauche ich doch ein SIP-Passwort und woher bekomme ich dieses?

  • Du hast bei "VLAN für Internettelefonie wird benötigt" die VLAN ID 360 eingegeben und erst dann hat der Internetzugang funktioniert?

    Das fällt mir schwer zu glauben.


    Im DG Portal steht bei einem kundeneigenen Router folgendes:

    "kundeneigener Router - Anschlussmodell FibreTwist (NT)"

    In diesem Falle benötigt man gar keine VLAN-IDs, sondern schließt die FB an den NT an und das war es für den Internetzugang.

    Gleich ob kundeneigener Router oder nicht. Im Portal müssen die SIP Rufnummern stehen. Üblicherweise erhälst Du einen Brief mit den Kennwörtern.

    Hast Du keinen erhalten, dann lass dir die Daten und Passwörter noch einmal schicken.


    So wie es sich für mich darstellt, gibt es bei dir einen Zustand, den es nicht geben sollte: Anschluss providerseitig als Standard/PremiumRouter angelegt, jedoch kundeneigenes Equipment provisioniert.


    Nachtrag: So etwas habe ich schon im Netz von DG gesehen, da lief aber auch die Telefonie ohne Eingabe von SIP-Daten, sonst wäre mir das gar nicht aufgefallen.

    Hast Du die Fernkonfiguration durch den Anbieter abgeschaltet? Falls ja aktiviere diese wieder und starte Mal die 7590 neu. Evtl. funktioniert die Telefonie dann ja von selbst.

  • Welche VLAN ID hätte ich bei einem kundeneigenen Router eingegeben? Oder gar keine? Unter welchem Anschluss laufe ich, wenn es kein DG und kein kundeneignener Router ist?

    Was gibt es denn sonst für eine Möglichkeit?! Dachte man bringt eigene Hardware mit (Kundeneigener Router) oder mietet bei der DG?!

  • Nach allem, was ich bislang gesehen habe, kommt an den Anschlüssen, für die eine 5530 an GPON registriert wurde, gar keine VLAN ID zum Einsatz. Wir hatten hier mal exportierte Konfigs einer 5530, die per Aktivierungscode an einem DG GPON Anschluss aktiviert wurde. Ich hatte damals den Verdacht, dass sowas wie VLAN IDs automatisch via TR069 konfiguriert werden, aber das war nicht der Fall. In der Konfig waren keine.


    Das heißt, wir hätten drei Varianten:

    - DG Router (AON + GPON): VLANs 360 (Internet) und 330 (Telefonie), sowohl vor als auch hinter dem ONT

    - kundeneigener Router (AON + GPON): VLAN 362 für Internet und Telefonie, aber nur vor dem ONT. Hinter dem ONT gibt es keine VLAN ID

    - GPON Anschluss mit aktivierter 5530: gar keine VLAN ID.