Beiträge von Bracew

    Ich vermute, dass es noch geht.

    Nein, geht nicht mehr.


    Im Januar 2021 wurde mein Anschluss nach meinem Antrag über Nacht von DG Sagemcom Mietrouter auf kundeneigenen Router (FB 7590) umgestellt.

    Über den DG Sagemcom Mietrouter war dannach kein Internet Zugang mehr möglich.

    Der Mietrouter wurde zurück gefordert.

    Hallo,

    ich habe auch den DG 1000er Tarif mit einem FB 7590er Router.


    Anfangs dachte ich auch, dass der Anschluß nicht die versprochenen Übertragungsrate von min 900 MBit/sec. liefert. Ich habe mich dann an die DG gewandt und ein freundlicher Mitarbeiter hat mehrmals mit mir telefoniert und nach einer Lösung gesucht.


    Ich wurde ersucht ein spezielles Speedtest-Programm auf einem Win10 PC zu laden. Letzten Endes haben wir rausgefunden, dass es


    a) an meinem PC gelegen hat.

    Mein Desktop-PC hat eine Onboard-LAN-Buchse auf dem Motherboard, welche ich einige Jahre nicht genutzt hatte. Mit dieser funktionierte im Dual-Boot System zwar Windows aber nicht Linux. Statt die Motherboard-LAN-Buchse zu nutzen hatte ich eine TP-Link Gigabit PCI-Karte (TG-3269) extra eingebaut um mit Windows und Linux den PC nutzen zu können.

    Sobald ich die extra TP-Link Gigabit PCI-Karte entfernt habe und es wieder mit der Motherboard-LAN-Buchse versuchte erreicht der Desktop-PC die 900 MBit/sec. Mittlerweile wird die Motherboard-LAN Buchse auch von meinem Linux unterstützt.


    b) sehr von der Gegenstelle und dem tageszeitlich bedingtem sonstigen Verkehr abhängt. Zeitweise erreicht mein Windows-PC bis 945 MBit/sec. bei Wahl der "richtigen" Gegenstelle im Speedtest-Programm. Andere Gegenstellen Provider kommen da nicht mit. Zur selben Zeit teilweise unter 200 MBit/sec im Download. Die Leistungen der Gegenstellen schwanken sehr stark. Manchmal ist ein Provider sehr schnell, andere male wieder nicht. Hängt vielleicht auch vom Routing der DG ab. Gute Erfahrungen habe ich mit NetCologne als Gegenstelle gemacht.


    c) mein PC mit keinem der Speedtest-Programmen im Browser die selbe Geschwindigkeit erreicht, wie mit dem speziellen Windows-Speedtest-Programm.


    Versuch es mal mit unterschiedlichen Endgeräten (PC) am Netzwerkkabel (Nicht per WLAN), welche für Deine Tests allein an der FB7590 hängt.


    Gruß Bracew

    Mittlerweile habe ich auf dem Produktiv-RasPi PiVPN mit WireGuard installiert.


    Via IPv6 schien es gut zu laufen, aber heute

    • kam zunächst keine Verbindung vom externen Smartphone zum internen WireGuard-RasPi zustande. Erst nach einem Reboot des WireGuard-RasPi war die Verbindung ok.
    • Eine weitere Einschränkung (oder Fehler in meiner Config?) habe ich derart festgestellt, dass die Dateimanager-App auf meinem Smartphone die Freigaben des Samba-Servers auf dem WireGuard RasPi zwar sieht, aber keine Verbindung herstellen kann bzw. kein Zugriff möglich ist. Auch manche interne Websites (z.B. FHEM) auf dem internen WireGuard-RasPi sind nicht erreichbar.
      Der Zugriff auf andere Samba Freigaben und Websites auf anderen internen Geräten funktionieren gut.

    IPv4 habe ich noch nicht in Angriff genommen. Das von tec79 empfohlene Produkt scheint mir zu kompliziert und etwas teuer für meine privaten Zwecke.

    Bei mehreren Telefonaten mit einem Mitarbeiter der Deutschen Glasfaser mit vielen Speedtests wurde von mir verlangt diese Tests mit NetCologne als Gegenstelle durchzuführen, da diese nach seinen Erfahrungen die beste Performance haben.

    Letzten Endes war der Fehler an der Netzwerkkarte (max. 650 MBit/sec. im Download) meines PC. Mit einer anderen Karte waren mit NetCologne bis 945 MBit/sec. drin (Tarif DG giga 1000). Andere Gegenstellen Provider kommen da nicht mit. Zur selben Zeit teilweise unter 200 MBit/sec im Download.

    Hallo dkweb,


    danke für Deine Hinweise.


    Zunächst einmal war ich in der Zwischenzeit nicht tatenlos.

    Ich habe unterdessen den SagemCom F@st 5366se Router gegen eine Fritzbox 7590 getauscht und auf einem ungenutzten Test RasPi PiVPN installiert. PiVPN kann entweder OpenVPN oder WireGuard.



    Im ersten Versuch habe ich OpenVPN ausgewählt. Das war jedoch Erfolglos.


    Im zweiten Versuch habe ich WireGuard ausgewählt.


    Mit WireGuard habe ich VPN Verbindungen hinbekommen, aber nur wenn auf dem externen Geräten (Android 11 Smartphone bzw. Debian 9 Netbook) jeweils eine IPv6 Verbindung zur Verfügung stand. Eine Verbindung im O2-Mobilfunknetz (hat leider kein IPv6) oder an einem WLAN-Hotspot (meist nur IPv4) war so nicht möglich. Als WireGuard-Port habe ich den Standard UDP Port eingestellt. Unter https://www.wireguard.com/known-limitations/ steht "WireGuard explicitly does not support tunneling over TCP, ..." so dass ich wohl bei UDP bleiben müsste.


    In den nächsten Tagen wollte ich meine Testinstallation eigentlich auf meinen Produktiv-RasPi umsetzen, nach dem Motto, lieber nur ein IPv6-VPN als gar kein VPN, in der Hoffnung ggf. mal die Nadel im Heuhaufen zu finden und unterwegs ein WLAN-Gastnetz mit IPv6 zu bekommen.

    Nun überlege ich mir aber, ob Du mir Deinen Ansatz

    Dann habe ich auf einem günstigen VServer der eine Public IPv4 und Public IPv6 Adresse hat 6tunnel installiert und ein Mapping auf mein OpenVPN-IPv6-Socket gemacht und schon kommt man auch per IPv4 auf den VPN drauf.

    etwas laienhafter und nachvollziehbarer erklären kannst, damit ich zunächst Deinen Vorschlag noch ausprobieren kann.


    Wo hast Du einen "...günstigen VServer..." her?

    Wie hast Du dort "...6tunnel installiert und ein Mapping auf mein OpenVPN-IPv6-Socket ..." installiert?

    Was müsste ich noch auf dem RasPi tun?

    Geht das auch mit UDP?

    etc.?


    Gruß Bracew

    Folgende E-Mail der DG von gestern:

    Mit Punkt #14 wird auf den Beitrag Nr. 14 hier in diesem Thread verwiesen.


    Aufgrund des Hinweises oben: "Allerdings würde ich Ihnen zu einem AVM Modell raten, da wir die Erfahrung gemacht haben, dass diese Geräte für Ihre zwecke besser geeignet sind." habe ich mir heute eine AVM FritzBox 7590 für 159,99 bei Saturn geholt. Saturn geht auf den zur Zeit günstigen Mediamarkt Preis ein. Ich habe mich nun auch lange genug mit dem Sagemcom Router beschäftigt und werde ihn "....bald gegen die Wand wo es hängt."

    Heute über nacht auf Morgen wird die Umstellung der DG auf "Kundenrouter" sein. Ich bin gespannt.

    Man muss das Rad ja nicht immer neu erfinden: http://letmegooglethat.com/?q=raspberry+pi+vpn+server

    Ja, gegooooooogle hatte ich das auch schon. Es gibt aber sooooooo viele Anleitungen, dass einem schon ganz schwindelig davon werden kann. Deshalb frage ich ja hier im Glasfaserforum.de und nicht im RasPi-Forum nach "Hat jemand das schon gemacht und kann mir Hilfe oder eine (funktionierende und getestete) Anleitung", weil damit auch Dein Hinweis zur

    IPv6 Erreichbarkeit:

    gegebenenfalls berücksichtigt ist.

    Ich hoffe meist zunächst mal auf das Beste: jemand hier im Forum hat die Eierlegende....-Anleitung ausgeführt und sie funktioniert! Am liebsten mit IPv4 und IPv6 also sozusagen von überall (Internetanschlüssen/WiFi-Hotspots/Mobilfunk etc.) mit allem Schnick-Schnack und Pi-Pa-Po.


    Die

    ausführliche und bebilderte Anleitung

    ist wirklich schön, hat aber den Nachteil nur auf IPv4 einzugehen. Nichts desto trotz war auch PiVPN eine Möglichkeit in meiner bisherigen engeren Wahl.


    Es gibt auch VPNs, die hinter CGNAT funktionieren, z.B. ZeroTier und SoftEther. Die bedienen sich externer Server, um Verbindungswünsche zu signalisieren, und nutzen dann Tricks oder Relayserver, um Verbindungen durch NAT hindurch herzustellen.

    Einen externen Webspace (1&1) hätte ich, ob dieser auch als externer Server taugt, müsste ich nachfragen. Was soll der externe Server können? Hast Du eine (für IPv6 Glasfaser) funktionierende Anleitung?

    Hallo,


    ich habe einen Internet-Anschluß von der Deutschen Glasfaser (DG) mit von der DG bereitgestellten SagemCom F@st 5366se Router und möchte gerne einen

    • VPN (Virtual Private Network) Zugang

    von meinem Debian9-Laptop, Windows10-Laptop und/oder meinem Android11-Smartphone von irgendwo in der Welt in mein Heimnetz einrichten.


    Der Sagemcom-Router bietet dazu meines Wissens nach keine VPN Möglichkeit. In meinem Heimnetz läuft aber u.a. ein Raspberry Pi mit Raspbian Buster. Auf dem RasPi läuft ein ddclient-Dienst, welcher eine Subdomain von dynv6.com aktualisiert, sodass mit MeineSubdomain.dynv6.com eine Weiterleitung zur IPv6 des RasPi existiert. HTTP-Zugriff von außen funktioniert, ping6 leider nicht.


    Gibt es eine Möglichkeit ohne weiteres Geld (WAF) investieren zu müssen ein VPN einzurichten?

    Hat jemand das schon gemacht und kann mir Hilfe oder eine (funktionierende und getestete) Anleitung dazu geben?


    Danke Bracew

    Hallo,


    heute habe ich den Glasfaser Router auf der "IPv6 Firewall"-Seite geöffnet und alle Angaben aus Beitrag #32 waren gedreht bzw. vertauscht, also alle Eingaben aus der "Lokaler Port"-Spalte standen in der "Remote-Port"-Spalte und umgedreht.


    Ich habe den Testaufbau (Beide Router im Heimnetz trennen) nochmals hergestellt und neu getestet. Auf dem DG Router SagemCom F@st 5366se habe ich die Einträge von gestern auf der "IPv6 Firewall"-Seite (Beitrag #32) gelöscht und neue Einträge erstellt. Zwischendurch den Router neu gestartet.

    Den socat Test habe ich durchgeführt und er hat funktioniert. Meine lokale Internet Seite auf dem RasPi ist von außen erreichbar.


    Aber sobald ich wieder auf dem SagemCom Router die "IPv6 Firewall"-Seite öffne sind die Angabe in den Spalten "Lokaler Port" und "Remote-Port"wieder vertauscht:



    Trotzdem funktioniert socat und HTTP(s) Zugriff!

    Zur Dokumentation hier noch die Informationen zum Versionsstand meines Deutsche Glasfaser Basic Router SagemCom F@st 5366se:



    Nun werde ich meine getrennten Netze mal wieder zusammenführen und im laufe der Woche weitere Versuche zur Portfreigabe machen.


    Im Fall des Fehlerfalls oder wenn ich Fragen hätte, würde ich mich wieder melden.


    Ich danke allen Beteiligten für Ihr Engagement und Ihre Beiträge!

    Wenn ich das also richtig verstehe, ist meine obige Regel "Http-0" aus dem Beitrag 32 das Muster für mögliche Portweiterleitungen von jedweden Computer im Internet auf meinen RasPi zum angegebenen Port im Intranet hinter dem SagemCom Router. Nach diesem Muster könnte ich auch Mail bzw. VPN Ports öffnen und nutzen.


    Um einen Port so einstellen zu können muss man den Javascript-Eingriff aus Beitrag #14 mit dem * für die Remote-IP-Adresse nutzen, und dies geht nur nach dem Kniff (Javascript-Modifikation):

    Zitat

    Code

    1. $.util.isValidIpv6 = function(str) { return true; }

    Du musst dafür die Javascript-Konsole des Browsers öffnen. Zum öffnen der Dev-Tools im Firefox oder Chrome F12 drücken (alternativ Rechtsklick -> Untersuchen) und auf den Reiter "Console" klicken. Dort kannst du den Befehl von oben einfach eingeben. Dann einfach das Formular ausfüllen und die Validierung sollte nicht mehr meckern.

    nutzen.

    In sofern hat der Router meines Erachtens ein Fehler in der Software.