Glasfaser & Fritzbox: Fehlergrund 2: DHCPv4 no answer on discover

  • Hi, in einer Facebook-Gruppe für Glasfaser in Delbrück gab es bei einem Kunden, der bei der Deutschen Glasfaser einen Internetanschluss gebucht und bereits erhalten hat ein Problem. Er hatte seine Fritzbox direkt am Glasfasermodem (welches vom Anbieter zur Verfügung gestellt wurde) angeschlossen. Die Fritzbox übernahm jedoch den Verbindungsaufbau - hierzu muss man die Zugangsdaten des Glasfaseranbieters in der Fritzbox hinterlegen und der Fritzbox auch mitteilen, dass das extern angeschlossene Modem die Verbindung herstellen soll.


    Nach wenigen Wochen hatte der Kunde KEINE Verbindung mehr. Folgende Fehlermeldung trat auf: Fehlergrund 2: DHCPv4 no answer on discover
    Der Techniker der "Deutsche Glasfaser" und auch die Hotline konnten keine Störung feststellen. Auch eine andere Fritzbox funktionierte nicht. Die Lösung war aber am Ende dann eine ganz einfache:


    Im FritzOS müsse man unter Internet > Zugangsdaten in den VLAN Einstellungen eine ID hinterlegen. Diese ID ist offenbar auch für andere Anschlüsse allgemeingültig: Sie lautet VLAN-ID 362 (Häkchen bei VLAN-ID verwenden nicht vergessen).


    Großer Dank geht hier an Jörg E. - diese Info stammt von der oben erwähnten Facebook-Gruppe.

  • Danke für den Tipp! Hat bei mir super funktioniert. Vorher war ich echt verzweifelt. Auf die VLAN Einstellungen wäre ich nie im Leben gekommen. Jetzt läuft alles. Danke!!!

  • Hallo,


    ich hatte, wie oben dargestellt, das gleiche Problem an einer Fritzbox 7590.

    Die Frage war nur: wo trage ich die VLAN-ID ein?


    Dazu folgende Vorgehensweise:

    > Zugungsdaten

    > Internetanbieter: "weitere Anbieter"

    > "andere Anbieter" (nicht Deutsche Glasfaser, denn die dort hinterlegten Daten sind falsch, und man kommt nicht an die VLAN-ID)

    > Name (muss nicht ausgefüllt werden)


    > Anschluss

    * Anschluss an externes Modem oder Router

    > Betriebsart

    * Internetverbindung selbst aufbauen


    > Zugangsdaten

    * Nein


    > Verbindungseinstellungen

    Downstream [z.B. 100000] kbit/s

    Upstream [z.B. 100000] kbit/s


    > Verbindungseinstellungen ändern (öffnen)
    * VLAN für den Internetzugang verwenden

    VLAN-ID [ 362] (für Hessen - laut AVM-Fritzbox-Support kann die Nummer in anderen Regionen anders sein)

    IP-Einstellungen

    * IP-Adresse automatisch über DHCP beziehenDHCP-Hostname


    ÜBERNEHMEN

    ----


    Das war's. Mit diesen Einstellungen hat die Fritzbox bei mir mit dem Glasfasernetzwerk GEARBEITET.

  • Hallo zusammen,


    ich hatte genau das gleiche Problem. Da der Support von DG nicht willens oder in der Lage war, mir zu helfen, war ich sehr froh, die hier beschriebene Lösung gefunden zu haben.

    Diese hat ca. 1 Woche stabiles Internet mit maximaler Geschwindigkeit gebracht. Bis gestern. Als ich von der Arbeit heimkam hatte ich bemerkt, dass das WLAN kein Internet mehr bereitstellt. Ich habe die Fritzbox 7590. Sie zeigt ist nun wieder den selben Fehler Fehlergrund 2: DHCPv4 no answer on discover.


    Leider habe ich die Fehlerhistorie, die in der Fritzbox gespeichert ist, nicht mehr, da ich diese inzwischen zurückgesetzt habe. Ich weiß noch, dass die Internetverbindung in den letzten Tagen immer wieder mal abgebrochen war (ohne dass ich es bemerkt hätte). Der letzte Fehlereintrag war dann der oben genannte.


    Die Router-Einstellungen waren auch leicht verändert, so stand bei "Anbieter" nun plötzlich "Glasfaser" (nicht jedoch "Deutsche Glasfaser"). Ich hatte ja ursprünglich "weiterer" bzw. "anderer Anbieter" gewählt.


    Das schlimme ist, selbst wenn ich die hier genannten Einstellungen (mit der Vlan-ID) wieder einstelle, habe ich dennoch kein Internet mehr. Wahlweise erscheint der bekannte Fehler oder aber "unbekannter Fehler".

    Ich habe sowohl das DG-Modem resettet als auch die Fritzbox neu gestartet. Selbst das Kabel zwischen den beiden Geräten habe ich ausgetauscht (durch ein Cat7 Kabel).

    Alles ohne Erfolg.


    Mit fallen nun keine Optionen mehr ein außer eventuell bei DG nach einem Austausch-Modem zu fragen. An der Fritzbox liegt es laut AVM nicht.


    Oder gibt es vielleicht noch eine andere VLAN-ID, die ich ausprobieren könnte? Ich wohne in Hessen, direkt an der Landesgrenze zu Bayern. Keine Ahnung, ob das hilfreich ist, ich weiß offengesagt nicht, was eine VLAN-ID ist...


    Kann jemand helfen?

  • Hallo Timo und willkommen im Forum,


    soweit ich weiß, gibt es nur die VLAN ID 362, die funktionieren sollte. Besteht die Möglichkeit, einen Computer ohne Fritzbox direkt an das Glasfasermodem anzuschließen und die Internetverbindung darüber zu testen? Das wäre zumindest ein Weg um die Fehlerquelle eingrenzen zu können. Geht das Modem auch so nicht, kann man die Fritzbox ausschließen. Klappt die Verbindung, so stimmt etwas bei der Einwahl-Kommunikation zwischen Modem und Fritzbox nicht.

  • Hallo Timo,

    ich habe das gleiche Problem und habe am Glasfaserverteiler mit einem Techniker gesprochen. Der hat erzählt, dass ein Bagger den Glasfaserstrang zwischen Frankfurt und Mainhausen durchtrennt hat und dass sie einen neuen Strang einziehen und spleißen müssen. Dauert voraussichtlich bis morgen. Siehe auch die Seite mit aktuellen Störungen.

    Also erst mal die Reparatur abwarten und dann wieder probieren.

    Grüße

    Ein Zellhäuser


    PS: VLAN ID. Auf einer physikalischen Leitung können mehrere, voneinander getrennte, virtuelle Netze geschaltet sein. Diese VLAN's haben eine ID, damit die Router und Switche wissen wohin die Daten gesendet werden sollen.

  • Vielleicht ist es auch interessant, dass es anscheinend bei der Deutschen Glasfaser unterschiedliche VLAN IDs gibt.


    EInfach mal probieren:


    362
    361

    360
    363
    320


    Beim mir war es 362, beim direkten Nachbarn war es die 360.


    Ansonsten die Hotline anrufen und nachfragen welche korrekte VLAN ID für deinen Anschluss gilt.
    Angeben, dass du eine eigene Fritzbox anschließen willst.

  • Hallo zusammen,


    es funktioniert wieder! Der Hinweis auf die Störung war richtig. Ich hatte heute nachmittag eine E-Mail von DG dazu erhalten. Bißchen spät, aber ok.

    Danke an den Zellhäuser für den Link (Grüße aus Mainflingen)! Jetzt weiß ich wenigstens, wo ich das nächste Mal zuerst nachschaue, bevor ich mich verrückt mache...