IPv6 an Deutsche Glasfaser-Anschluss funktioniert nicht

  • Hallo,


    bei unserem Anschluss der Deutschen Glasfaser bekommen meine direkt an den ONT angeschlossenen Geräte keine IPv6-Adresse zugewiesen.

    D.h., wenn ich meine PCs direkt an den ONT (Nokia G-010G) anschließe und DHCP-Client aktiviere, dann wird mir mit ifconfig für eth0 eine fe80-Adresse angezeigt, aber nur diese und keine weiteren Adressen, kein Gateway, kein DNS-Server.

    Wenn ich meinen Router (LevelOne WGR-8031) anschließe und IPv6 aktiviere, bleiben die Felder für Gateway und DNS leer.


    Für mich sieht das so aus, als würde der DHCP-Server der DG nicht funktionieren. Liege ich damit richtig?

    Gibt es auf meiner Seite etwas, was ich testen könnte, oder sollte ich bei der DG nachfragen?

    Gibt es eine einfach zu merkende, öffentliche IPV6-Adresse, die man anpingen kann?


    Ich habe in der Anleitung des ONT gelesen, dass man sich damit per Telnet verbinden kann, was aber nicht funktioniert. Ist das normal, oder ist das ein Indiz dafür, dass das Gerät defekt oder falsch konfiguriert ist?


    IPv4 funktioniert, sowohl mit Router, als auch direkt mit PC am ONT.

  • Der IPv6 DHCP-Server lässt sich auch im Normalfall manchmal viel Zeit. Der nimmt es auch übel, wenn er zu viele wechselnde Geräte direkt am NT sieht, und schmollt dann. Wenn ein Router auch nach längerer Wartezeit keine Adressen bekommt, kann man versuchen, das Problem an der Hotline zu erklären. Nicht damit abwimmeln lassen, dass der Router doch eine fe80-Adresse habe.


    Ohne eigene IPv6 Adressen nützt auch keine leicht merkbare IPv6 Adresse zum anpingen etwas, aber 2001:4860:4860::8888 ist einer der öffentlichen Google DNS-Server. Der antwortet auf Pings. FE80-Adressen sind link-local Adressen, die nicht geroutet werden. Die dienen nur der Kommunikation mit anderen Geräten im selben LAN. Den Google-DNS kann man damit nicht anpingen.


    Sobald der G-010G ONT glasfaserseitig eine Verbindung hat, ist er nicht von der Ethernetseite erreichbar. Das ist keine Fehlkonfiguration und kein Hinweis auf einen Defekt.

  • Vielen Dank für die Infos. Wie lange sollte ich den Router am ONT angeschlossen lassen, damit er aufhört zu schmollen?


    Den G-010G habe ich auch ohne GF-Verbindung gestartet und versucht mich mit ihm zu verbinden. Da kam nix. Kann es sein, dass DG dessen IP-Adresse standardmäßig ändert?


    Das Manual scheint mir allerdings auch fehlerhaft zu sein, denn dort steht, dass man der Netzwerkschnittstelle des PC die Adresse geben soll, die man anschließend anpingen soll. Ich habe dem PC eine andere Adresse gegeben, aber es funktioniert dennoch nicht. Ist die Adresse vielleicht falsch?

  • Das online zu findende Handbuch passt nicht zu der Firmware, mit der der NT ausgeliefert wird. Es gibt da aber auch wirklich nichts einzustellen oder zu sehen, was irgendwie wichtig wäre. Ich habe nachgeschaut.


    Wegen des DHCPv6 Servers würde ich mal einen Tag warten, wenn man vorher am Anschluss experimentiert hat.

  • Ah, OK, dann sitzt du offensichtlich an der Quelle :-)

    Ich hatte zwar nicht vor, dran rumzufummeln, aber ich hatte die Hoffnung, dass ich dort mehr Infos (Fehler- oder Statusmeldungen) bekommen könnte und grundsätzlich kann es nie schaden, wenn man selbst Zugriff hat.


    Nach welcher Zeit sollte sich der ONT, bzw. der DHCP-Server gefangen haben? Gestern hatte ich den Router 3-4 Stunden angeschlossen, aber auch danach habe ich keine IPv6-Adresse erhalten.

  • Ich sitze genau so viel oder wenig an der Quelle wie du. Ich bin DG-Kunde mit einem Anschluss, an dem ein G-010G-P werkelt.


    Den NT kann man auf Werkseinstellungen zurücksetzen. Hinter einem kleinen Loch auf der Seite mit den Anschlüssen befindet sich ein Taster. Den drückt man leicht und hält ihn etwa 10 Sekunden gedrückt, bis alle LEDs zweimal geblinkt haben. Der ONT sollte nach meinem Verständnis nicht an der Adressvergabe beteiligt sein. Die DG verlangt diesen Werksreset aber sogar selbst, bevor man einen Speedtest durchführt, wenn man Probleme mit der Geschwindigkeit meldet. Also kann der Werksreset anscheinend nicht schaden.


    Der Router muss seine Adresse und das Präfix für die Geräte im LAN per DHCPv6 abrufen. Die Router Advertisements schreiben "managed address configuration" vor. Das 331 Seiten starke Handbuch des Level1 Routers hat dazu eine halbe Seite (S.232) und wenn die Einstellung "AUTO" nicht das Richtige macht, dann geht es wohl nicht. Die anderen genannten Wahlmöglichkeiten ("static IP", "PPPoE" und "Bridge") sind jedenfalls falsch.


    Ich würde zumindest zur Fehlersuche immer einen OpenWRT-Router oder eine Fritzbox bereithalten, selbst wenn es nur 100Mbit/s-Geräte sind. Die sind so verbreitet, dass man davon ausgehen kann, dass die an einem funktionierenden Anschluss laufen.

  • Sorry für die späte Rückmeldung, aber Weihnachten schlägt zu.


    Werksreset des NT habe ich schon probiert, ändert aber nichts.


    Eine kompatible Fritzbox wäre wahrscheinlich der sicherste Weg, um herauszufinden, ob das Problem am Anschluss oder an den bisher angeschlossenen Geräten liegt. Ich werde mir so etwas mal zulegen. Da aber weder der Router noch mehrere PCs mit unterschiedlichen Betriebssystemen eine IPv6-Adresse zugewiesen bekommen haben, und ich nicht davon ausgehe, dass das bei allen Systemen falsch gemacht wird, tippe ich im Moment auf den Anschluss, bzw. dessen Konfiguration als Ursache.


    Ich habe die Deutsche Glasfaser inzwischen auch angeschrieben und das Problem beschrieben. Daraufhin haben die mir allerdings nur einen Link zu einer kurzen Anleitung für eine Fritz 7390 geschickt, was mich nicht weiterbringt, sondern eher mehr Fragen aufwirft. Unter anderem wird dort auf Seite 3 ein Haken bei "Dual Stack" gesetzt. Ob das notwendig ist, oder ob es auch ohne IPv4 funktionieren sollte, kann man dem nicht entnehmen.

  • Gerade dieses Testen mit mehreren Geräten scheint solche Probleme auch mal auszulösen. Die Anschlusskonfiguration bei der DG scheint mir nicht sehr robust zu sein. Eigentlich müsste es ja möglich sein, es auf Anbieterseite so zu konfigurieren, dass nur das letzte Gerät bedient wird, welches sich am Anschluss gemeldet hat, und alle vorherigen Adresszuweisungen damit verfallen. Das ist aber nicht so. Es werden u.U. mehrere Präfixe gleichzeitig auf einen Anschluss geroutet, wenn mehrere Router/Geräte hintereinander per DHCP angefragt haben. Vermutlich deshalb "wehrt" sich der Anschluss, wenn er zu viele Geräte sieht.


    "Immer eine native IPv4-Anbindung nutzen" auf Seite 3 der Anleitung für die Fritzbox 7390 ist die universelle Einstellung. Man kann nicht an allen DG-Anschlüssen IPv6 ohne IPv4 nutzen, weil IPv6 an älteren Anschlüssen teilweise mittels 6rd getunnelt wird, und dafür wird IPv4 benötigt. Eine reine IPv6-Konfiguration müsste möglich sein, aber wirklich getestet habe ich das nicht, und man kommt ohne IPv4 auch noch nicht zurecht.


    Das Problem, dass keine IPv6 Konfiguration zugewiesen wird, wird auch in anderen Foren immer wieder mal vorgetragen. Eine wirkliche Lösung habe ich bisher noch nicht gesehen. Der Support kümmert sich nicht wirklich um kundeneigene Router. Am ehesten kommt man noch zu einem Ergebnis, wenn man eine Fritzbox hat, weil die DG inzwischen auch selbst Fritzboxen vermietet. Sonst muss man schon genau belegen können, dass die Ursache auf der Netzbetreiberseite liegt. Die Supporter schieben die Schuld sehr schnell auf den Router des Kunden. Ich hatte das Problem auch schon und konnte es nur durch DUID-Änderung "lösen", bei ansonsten identischer Konfiguration. Die DG muss in Sachen problemlose Anschlusskonfiguration noch sehr viel lernen, besonders weil der Support praktisch keine Hilfe ist, wenn man nicht hartnäckig und gezielt mit Fachwissen nachhaken kann.

  • Für mich gehört das Thema Computernetzwerk nicht zum Alltagsgeschäft und zu DUID habe ich wenig gefunden. Ich meine aber verstanden zu haben, dass darüber ein "System" eindeutig erkannt werden kann. Wenn die Server bei DG nicht in der Lage sind, trotz der DUID festzustellen, dass sich auf der Clientseite etwas geändert hat, dann würde ich das als Systemfehler bezeichnen. Vielleicht nehmen die sich dieser Probleme deswegen nicht an, weil sie so die Routerwahlfreiheit untergraben und die Kunden eher zu Leihroutern bewegen können.


    Wenn es mir mal langweilig werden sollte, richte ich vielleicht mal einen DHCP-Server auf einem Testrechner ein und hänge den Level1-Router dort dran. Wenn der Router dann eine IPv6-Adresse bekommt, dann dürfte es an DG liegen.

  • Der DUID ist der DHCP Unique Identifier. Warum der DHCPv6 Server teilweise auf Requests mit einem bestimmten DUID-Wert auch nach längerer Zeit nicht antwortet, auf Requests vom selben Gerät nach Änderung des DUID aber dann doch, weiß nur die DG. Ich finde das auch merkwürdig. Man könnte zwar sagen, dann ändere ich eben den DUID, aber das ist bei vielen Routern gar nicht vorgesehen.


    Es ist möglich, dass der Level1-Router unter "AUTO" nicht eine automatische Protokollauswahl sondern nur die "stateless address autoconfiguration" (SLAAC) versteht, also dass sich der Router mit Hilfe eines per Router Advertisement gelernten Präfixes selbst eine Adresse erzeugt und per Neighbor Discovery überprüft, dass die nicht schon verwendet wird. Die Router Advertisements am DG-Anschluss verkünden aber kein Präfix, sondern nur, dass "managed address configuration", also DHCPv6, zu verwenden ist.

  • Beim Level1 WGR8031 sehe ich zumindest keine Möglichkeit, die DUID zu ändern. Es würde mir auch nichts bringen, denn ich weiß nicht, welche vom Server erwartet wird. Davon abgesehen wäre es ein massiver Nachteil, wenn der Server nur eine Gerät akzeptiert, denn dann kann man als Endbenutzer nicht mal eben den Router wechseln, was besonders im Falle eines Defektes sehr störend sein kann.


    Das Handbuch ist bzgl. IPv6 sehr sparsam. Die Konfigurationsseite für WAN sieht so aus. Damit kann man nach meinem Verständnis einstellen, ob der Router SLAAC oder DHCPv6 verwenden soll. Wenn der Router macht, wonach das Menü aussieht, dann sollte das also kein Problem sein.


    PS: Die DUID habe ich teilweise unkenntlich gemacht, da ich nicht abschätzen kann, ob damit Unfug getrieben werden kann.

  • Der Server akzeptiert ganz sicher mehr als nur ein Gerät, aber halt nicht viele in kurzer Zeit. Und manchmal scheint es den Fehler zu geben, dass ein bestimmtes Gerät partout keine IPv6 Adressen bekommt. Wenn man den DUID ändert, bekommt das Gerät dann vielleicht doch Adressen.


    Die WAN-Konfiguration beim Level1-Router sieht so aus, als müsste es gehen (auch wenn ich wegen der Firewall-Geschichte aus dem anderen Thread nicht weiß, warum das überhaupt erstrebenswert ist). Der DUID-Wert ist vom Typ "Link-Layer". Nach der 0003, die diesen Typ kennzeichnet, kommt 0001 für Ethernet und dann wahrscheinlich die MAC-Adresse vom WAN-Interface. Vielleicht kann man den Wert ändern, indem man eine andere MAC-Adresse cloned (weiter unten auf der Seite). Ich würde noch "PD Enable" (Prefix Delegation) einschalten, damit die Geräte im LAN auch Adressen bekommen können. Rapid Commit kann man auch mal probieren.

  • Mit letzterem hast du den Nagel auf den Kopf getroffen. Bevor ich deinen Beitrag gelesen habe, habe ich durch Trial+Error herausgefunden, dass "PD Enable" und "Rapid Commit" angehakt sein müssen. Dann bekomme ich IPv6-Adressen. Die PCs haben zuerst aber keine v6-Adressen bekommen, bzw. nur dann, wenn ich mit dem WLAN eines an einem DSL/ISDN-Anschluss laufenden Accesspoints, verbunden war. Da sind sich vermutlich die DHCP-Server in die Quere gekommen, aber da der AP kein IPv6 kann, verwirrt mich das.

    Im Moment brummt mir aber die Birne. Der Sache werde ich morgen auf den Grund gehen.


    IPv6 werde ich bei dem Level1-Router wahrscheinlich nicht benutzen, zumindest nicht dauerhaft oder solange nicht, bis es für die Firewallsache keine anständige Lösung gibt. Mir ging es im Moment darum, dass der GF-Anschluss gescheit funktioniert. Ich brauche den GF-Anschluss noch nicht, da ich bisher noch alles an einem alten DSL/ISDN-Anschluss angeschlossen habe, bei dem auch eingehende Verbindungen per IPv4 funktionieren und die Telefonie rockstabil ist.

  • Ein reiner AP muss auch kein IPv6 oder IPv4 können, was auf Layer 3 und höher passiert ist dem völlig egal :-).


    Je nach Router musst du das erhaltene /56-Präfix in /64-Präfixe subnetten und an dein(e) LAN-Interface(s) zuordnen. Fritzboxen machen das beispielsweise automatisch (da gibts auch nur eins :D), bei professionelleren Routern musst du das manuell machen. In der Regel findet man diese Zuordnung bei der Konfiguration für den DHCPv6-Client oder bei der Konfiguration des jeweiligen Interfaces. Unter Umständen muss man dann auch noch das Router-Advertisment konfigurieren, sodass dieses das Präfix via SLAAC oder DHCPv6-Server im Netzwerk ankündigt, dass machen aber auch professionellere Router-Lösungen meistens automatisch.


    Das PD Enable ist definitiv wichtig gewesen, sonst fragt der Router garnicht erst nach einem Präfix! Eigentlich müsstet du dann auch die Möglichkeit haben, die Präfix-Länge irgendwo anzugeben. DG verteilt /56-Präfixe. Bei meinem Anschluss ist es so, dass ich diese Präfixlänge auch wirklich korrekt im Router angeben muss, damit er ein Präfix bekommt.


    Die auf dem Markt zur Verfügung stehenden IPv6-Firewalls sind in der Tat noch häufig nicht zufriendenstellend oder zumindest nicht sonderlich benutzerfreundlich. Zur Zeit habe ich eine OpenSense Lösung im Einsatz, diese kann ich halbwegs empfehlen. Wechselnde globale Präfixes sind mitunter das größte Problem, für das kein mir bekanntes Firewall-System im Augenblick eine Lösung hat. Es wäre sinnvoll, wenn sich dort mal etwas in Richtung Wildcard-Präfixes entwickeln würde, denn im Endeffekt sind ja nur die Bits nach dem Global-Präfix für das Regelwerk entscheidend. Ich bin sehr froh, dass das /56-Präfix der DG halbwegs statisch ist. Ich habe seit 2 Monaten nun schon durchgängig das selbe Präfix. Für den Fall, dass es sich doch mal ändert, verwende ich Aliases. Dann brauche ich nur diese und nicht das Regelwerk verändern.

  • Ich wünsche Frohe Weihnachten gehabt zu haben!



    Ein reiner AP muss auch kein IPv6 oder IPv4 können, was auf Layer 3 und höher passiert ist dem völlig egal :-).


    OK, dann ist es wohl kein reiner AccessPoint, denn er stellt einen DHCP-Server zur Verfügung. Diesen kann ich nur für IPv4 konfigurieren, weshalb ich davon ausgegangen bin, dass er mit IPv6 nichts anfangen kann.


    Konkret sah das bei mir so aus:
    Ich habe einen DSL-Anschluss, über den ein PC mit pppoe eine Verbindung herstellt. Auf dem PC läuft Jana Proxy. Der AP ist mit dem LAN verbunden, stellt einen DHCP-Server bereit und verbindet die WLAN-Clients mit dem Proxy.


    Neulich habe ich dann den Level1-Router an den GF-Anschluss geklemmt und die beiden LANs miteinander verbunden. Auf dem Level1 war der DHCP-Server für das LAN aktiviert und er hat ein WLAN bereitgestellt. Ich hatte also ein WLAN vom alten AP und eins vom Level1.
    Als ich dann einen PC mit dem WLAN des Level1 verbunden habe, bekam dieser keine IPv6-Adresse.
    Wenn ich den PC mit dem WLAN des alten APs verbunden habe, bekam er eine IPv6-Adresse, obwohl im Webinterface des alten APs kein einziger Hinweis auf IPv6 zu finden ist.

    Nachdem ich den DHCP-Server des alten APs ausgeschaltet hatte, funktionierte das mit der IPv6-Zuordnung.



    Der Rest deines Beitrags klingt für mich so, als wäre IPv6 nach wie vor nur was für Experten und als würde es weiterhin nur stiefmütterlich behandelt werden. Funktioniert IPv6 bei OpenWRT einigermaßen und bekommt man das auch eingerichtet, wenn man nur gelegentlich mal was mit Netzwerken zu tun hat?


    Mir ist noch eingefallen, dass ich die Telefonfunktion nicht getestet habe und nicht weiß, ob dafür IPv6 notwendig ist.

  • Solche Konstruktionen mit verbundenen LANs hinter mehreren Routern sind sehr fehleranfällig. Das sollte man beim Testen auf jeden Fall vermeiden. Selbst wenn man weiß, was man tut, und schon sicher ist, dass die Router und Anschlüsse für sich alleine funktionieren, ist sowas nur schwer in den Griff zu bekommen.


    IPv6 hat noch viele Ecken und Kanten, und die Softwareunterstützung ist noch überraschend unvollständig. Ohne etwas Kampfgeist kommt man nicht weit.


    Die VoIP-Accounts von der Deutschen Glasfaser nutzen kein IPv6, auch nicht optional.

Erstelle ein Benutzerkonto oder melde dich an um zu kommentieren

Du musst ein Benutzerkonto haben um einen Kommentar hinterlassen zu können

Benutzerkonto erstellen
Neues Benutzerkonto für unsere Community erstellen. Geht einfach!
Neues Benutzerkonto erstellen
Anmelden
Du hast bereits ein Benutzerkonto? Melde dich hier an.
Jetzt anmelden