Mietrouter am Anschluss für Kundenrouter bei Deutsche Glasfaser

  • Ich hatte die Hoffnung, dass man den Mietrouter als preiswertes Reservegerät vorhalten kann. Am Anschluss für kundeneigene Router funktioniert der Genexis hier nicht, bzw. er stellt keine Verbindung ins Internet her. Per Googlesuche findet man sehr wenig über das Gerät. Nach einer alternativen Firmware brauche ich hier dann wohl nicht zu fragen :)

  • Wenn der Anschluss von DG-Router auf kundeneigenen Router umgestellt wird, fordert die DG den Router sowieso zurück. Einen Retourenaufkleber kann man sich auf der DG-Webseite erstellen. Andernfalls wird der DG-Router in Rechnung gestellt. Für das Geld würde ich mir eher ein anderes Gerät kaufen.


    Wer plant, einen anderen Router zu verwenden, sollte den DG-Router gar nicht erst mitbestellen. Das spart Zeit und Geld.

  • Wenn ich gewusst hätte, dass die DG den Anschluss mit einem Mietrouter so konfiguriert, dass dieser nicht mit einem eigenen Router funktioniert und umgekehrt, hätte ich diesen auch nicht dazu bestellt. Allerdings habe ich nirgendwo gelesen, dass es diese Einschränkung gibt, und ich hätte auch nicht damit gerechnet, denn meines Wissen gibt es Routerfreiheit und diese wird auf diesem Wege eingeschränkt.

    Dass die DG den Router zurückfordert, wenn ich den Anschluss für einen eigenen Router konfigurieren lasse, wusste ich auch nicht. Für einen nicht zurückgesendeten Router verlangen die hier kein Geld, wohl aber je 5 Euro für das Netzteil und das Ethernet-Kabel.


    Welcher Router taugt denn was am GF-Anschluss der DG? Die Fritz 7590, Digitalisierungsbox Premium oder be.ip Plus sollten funktionieren, aber das wäre hier wahrscheinlich vollkommen übertrieben. Wenn man auf einen Telefonanschluss verzichten kann, dann käme noch die Fritz4040 in frage.


    Bei einigen anderen Geräten anderer Hersteller habe ich davon gelesen, dass die die volle Bandbreite, die der Anschluss liefern kann, nicht übertragen können und bei den meisten Geräten findet man keine Info dazu. Hat hier jemand einen (Geheim :-)-Tipp? Irgendwas, was preiswerter als eine Fritz ist, aber nicht entscheidend schlechter?

  • Wenn man einen Router verwenden möchte, der für Telekom-Anschlüsse vermarktet wird, dann ist darauf zu achten, dass der Router die Verbindung nicht nur mit PPPoE sondern auch direkt per DHCP herstellen können muss. Die Speedports können das z.B. nicht und sind deshalb nicht für DG-Anschlüsse geeignet.


    Gigabit-LAN-Ports und WLAN mit 802.11ac sind keine Garantie für einen hohen Routingdurchsatz, der auch für schnelle Glasfaseranschlüsse ausreicht. Die tatsächlich erreichbare Datenrate zwischen WAN und LAN behandeln die meisten Hersteller als Geheimnis. Jedenfalls werben sie üblicherweise nicht damit. Im Web sind ein paar Listen zu finden, aber dort fehlen viele hierzulande übliche und verfügbare Geräte. Das Thema ist in Deutschland für viele noch nicht relevant. Hier zählt eher, ob der Router ein (Super-)Vectoring-taugliches Modem hat. Die meisten Internetnutzer können gar nicht mehr als 250Mbit/s bekommen, sehr viele auch nur deutlich weniger. Routingdurchsatz im Gigabitbereich zu benötigen ist ein "Luxusproblem".


    Ich empfehle, den Router nach den gewünschten Features (WLAN, VoIP, USB, VPN, Konfigurationsinterface, etc.) auszusuchen und dann zu recherchieren, ob der Router auch den benötigten Durchsatz bringt. Für ein konkretes Gerät kann man diese Information vielleicht beim Hersteller erfragen oder in Benutzerforen finden.

  • Deine Beschreibung deckt sich ziemlich gut mit meinen Erfahrungen. Die Hersteller halten einige Angaben (Datendurchsatz, Leistungsaufnahme) zurück und es scheint derzeit noch ein Luxusproblem zu sein, einen Router zu haben, der die Leistungsfähigkeit einer Glasfaserleitung nicht beschneidet.

    Zu den Fritzboxen bekommt man noch am ehesten Kundenmeinungen, da die sehr weit verbreitet sind. Bevor ich ewig suche, werde ich mir wohl eine Fritz 4040 zulegen. Lieber wäre mir eine preiswertere und sparsamere Kiste ohne WLAN, aber so etwas scheint es nicht zu geben. Telefon brauche ich noch nicht. Sollte sich das ändern, kann ich die Fritz wieder verkaufen. Wie ich gesehen habe, gehen die auch gebraucht noch gut weg, sodass es kein großer Verlust wäre.

    Neben dem Hauptrouter hätte ich gerne noch einen möglichst billigen Router, den ich als Reserve vorhalten kann. Wenn ein Gerät kaputt geht, dann ja meistens am Wochenende oder am 24.12. um 20:00 Uhr. Der Reserverouter muss nicht die volle Bandbreite durchsetzen, aber er sollte sehr zuverlässig sein. Spricht was gegen den "Level One WGR-8031"?

  • Der LevelOne WGR-8031 arbeitet mit einem Realtek Chipsatz. Realtek ist dafür bekannt, dass die WLAN-Treiber keine gute Qualität haben, und dass keine Bemühungen unternommen werden, Unterstützung für die Hardware in den Hauptzweig des Linux Kernels zu bekommen. Deshalb gibt es keine alternative Firmware für Realtek-Router. Die Originalfirmware arbeitet mit einem veralteten Kernel. Davon abgesehen wird der Router sehr wahrscheinlich am DG-Anschluss funktionieren. Zur Routing-Leistung ist nichts zu finden. Zur Zuverlässigkeit auch nicht.

  • Das sind wesentlich mehr Infos als ich gefunden habe. D.h., bei OpenWRT habe ich nichts zu dem Gerät gefunden.

    Eine alte Firmware und ein alter Kernel sind natürlich nicht optimal, aber solange das Ding zuverlässig läuft und keine Sicherheitslücken bekannt sind, sollte es nicht stören.


    Zur Routing-Leistung hoffe ich, dass die Maximalwerte für WLAN (866 MBps) auch für LAN und WAN erreicht werden. Da das Teil auch als WLAN-Router im LAN funktionieren sollte und wenig kosten, ist es eine gute Reserve und ich habe es mir bestellt. Unser Glasfaseranschluss ist derzeit auf 300 MBps eingestellt, sodass ich zumindest bis dahin die Leistungsfähigkeit prüfen kann. Wenn ich das Laptop direkt an den ONT anschließe, dann kommen bis zu 36 MB/s. Ich werde berichten.

    Die Anleitung zum WGR8031 ist 311 Seiten lang und enthält viele Screenshots. So viel Mühe macht sich nicht jeder Hersteller.



    Die Sache mit Realtek und Linux ist mir auch neu. Da ich plane auf Linux Mint zu wechseln, ist so etwas für mich interessant und hilft evtl. bei der Wahl anderer Hardware.

  • Unser Glasfaseranschluss ist derzeit auf 300 MBps eingestellt, sodass ich zumindest bis dahin die Leistungsfähigkeit prüfen kann. Wenn ich das Laptop direkt an den ONT anschließe, dann kommen bis zu 36 MB/s. Ich werde berichten.

    Auf das Ergebnis bin ich sehr gespannt. Man kann mit zwei Computern und einem vorhandenen Router auch ohne Glasfaseranschluss relativ einfach die (IPv4-)Routingleistung eines neuen Routers messen. Dazu schließt man einen Computer an einen Gigabit-LAN-Port des vorhandenen Routers an, startet dort einen iPerf3 Server und gibt ggf. den Port in der Firewall des Computers für ankommende Verbindungen frei. Den zu testenden Router schließt man mit dem WAN-Port ebenfalls an einen Gigabit-LAN-Port des vorhandenen Routers an. An einen LAN-Port des zu testenden Routers schließt man den zweiten Computer an und startet von dort die iPerf3 Tests als Client. Um Einschränkungen durch andere Einflüsse auszuschließen, sollte man den zweiten Computer auch mal am vorhandenen Router anschließen und den Test so im selben LAN durchführen. Dabei sollten ungefähr 940 Mbit/s möglich sein, sonst bremst irgendwas anderes. (Ein Test mit IPv6 ist etwas komplizierter, weil dafür auf dem ersten Router Prefix-Delegation konfiguriert werden muss.)

  • Würde es nicht ausreichen, 2 PCs an WAN und LAN des zu testenden Routers anzuschließen und die IP-Adressen der PCs in unterschiedliche Teilnetze zu legen?

    Natürlich würde das auch ausreichen, aber dann muss man das Netzwerk im Router und im WAN-seitigen Computer manuell einstellen. Einfacher ist es mit einem zweiten Router. (Ein wenig Glück, dass die Router nicht den gleichen IP-Adressbereich für ihre LANs verwenden, gehört aber auch dazu.)

  • Natürlich ...

    :-) Ich hantiere selten mit Netzwerken herum, sodass ich mir selbst bei einfachen nicht alltäglichen Dingen nicht sicher bin.


    Den Adressbereich im Router und den PCs einzustellen, dürfte kein Akt sein. Ich vermute, dass der WAN-seitige PC evtl. DHCP-Server sein muss. Da ich das mit Mint ausprobieren würde, sollte das mit isc-dhcpd kein Hexenwerk sein.


    iperf und jperf habe ich inzwischen auf einem Rechner zwischen Win und Linux mit einer VM getestet. Das funktioniert schon mal grundsätzlich.

  • Der zweite Router wäre nur dazu da, um per DHCP dem anderen Router und dem PC mit dem iPerf3 Server die Adresskonfiguration zu geben. Wenn man die Adresse des Server-PC und die WAN-Adresse des zu testenden Routers manuell einstellt, braucht man auch keinen DHCP Server. Man kann aber auch auf dem WAN-seitigen PC einen DHCP Server installieren und konfigurieren, anstatt die WAN-Adresse des Routers manuell zu vergeben. Wie immer gibt es viele Möglichkeiten.


    Ich wollte es nicht zu kompliziert machen. Router und PC an vorhandenen Router, zweiten PC an zu testenden Router und mit iPerf3 die Datenrate zwischen den beiden PCs testen. Nur wenn beide Router den gleichen Adressbereich für ihre LANs verwenden, muss man dann noch in die Netzkonfiguration eingreifen, um einen der Adressbereiche zu ändern. Sonst ist es einfach nur stöpseln, testen, fertig.

  • Der WGR8031 ist inzwischen eingetroffen und ich habe ihn kurz mit jperf zwischen zwei PCs getestet. Ob 1 oder 6 Verbindungen spielt keine Rolle. In der Summe werden immer immer ~900.000 kbit/s angezeigt. Erst wenn ich 10 Verbindungen herstelle, sinken einige Messwerte um 5 - 10 %. Also für den privaten Gebrauch scheint das ordentlich zu sein.


    Den WLAN-Teil habe ich nicht wirklich getestet, denn das Gerät soll im Keller stehen und dort brauche ich kein WLAN.

    Die Reaktion auf das Abschalten von WLAN per Webinterface ist etwas merkwürdig. Die Status-LED für WLAN blinkt weiterhin und die gemessene Leistungsaufnahme sinkt nicht. Wenn ich dagegen die Hardwaretaste am WGR8031 benutze um WLAN auszuschalten oder das Gerät neu boote, dann sinkt die Leistungsaufnahme um 0,7 W und die LED bleibt aus.

    Das mitgelieferte Netzteil ist billig und wird ziemlich warm. Ich habe das NT vom Genexis-Router genommen, welches deutlich kühler bleibt. So werden mit ausgeschaltetem WLAN und 2 PCs an WAN und LAN 2,4 W vom Wattmeter angezeigt. Das ist im Vergleich zu anderen Routern sehr ordentlich, vor allen Dingen, wenn die Fritzboxen mit 7 bis 16 W angegeben und getestet werden.


    Das Webinterface des Geräts ist extrem flink und es sieht aufgeräumt aus, sodass für mich bisher keine Fragen aufgekommen sind.

    Die beiden TP-Link-Router, die ich hier bisher für WLAN-AP und DSL-Routing im Betrieb habe, sind sehr viel langsamer. Beim WGR8031 habe ich dagegen eher das Gefühl, dass er genauso flink wie Thunar ist.


    Also für meine Zwecke scheint der WGR8031 gut geeignet zu sein.

  • Danke für den Test. Die Routing Performance ist viel besser, als ich erwartet hatte.


    Wenn ein Test mit IPv6 möglich ist, wäre das Ergebnis auch noch interessant, besonders für den Einsatz an einem Deutsche Glasfaser Anschluss. Die günstigen Router erreichen ihre Routingleistung oft nur durch Hardware Offloading, das aber teilweise nur für IPv4 implementiert ist.

  • Einen ipv6-Test würde ich gerne machen und das Ergebnis hier vorstellen, aber das bekomme ich nicht ohne größeren Aufwand oder kräftige Unterstützung hin.

    Standardmäßig ist IPv6 im Router deaktiviert und die Adressen stehen alle auf Null. Ich habe im Moment keine Ahnung, welche Werte ich dort eingeben muss, damit es sinnvoll ist, da ich noch nie etwas mit ipv6 gemacht habe.


    Für IPv4 habe ich WAN-seitig eine feste IP-Adresse im Router eingestellt und DHCP-Server für die LAN-Seite.


    Reicht es, bei jperf die Checkbox unten links zu setzen, bzw. den Schalter -V für iperf, damit der Test nur über IPv6 läuft?


    Ich vermute, dass ich diese beiden Konfigurationsseiten bearbeiten muss:

    LAN-Settings

    WAN-Settings

  • Ich vermute, dass ich diese beiden Konfigurationsseiten bearbeiten muss:

    LAN-Settings

    WAN-Settings

    Im Prinzip das gleiche wie bei IPv4: Die beiden PCs brauchen jeweils eine Adresse, eine Netzmaske und ein Gateway. Der Router braucht eine WAN-Adresse, eine WAN-Netzmaske, eine LAN-Adresse und eine LAN-Netzmaske. Alles andere ist optional. Konkret:


    PC auf der WAN-Seite: fd01::3, Präfixlänge 64, Gateway fd01::2


    Router WAN-Seite: fd01::2, Präfixlänge 64

    Router LAN-Seite: fd02::1, Präfixlänge 64


    PC auf der LAN-Seite: fd02::2, Präfixlänge 64, Gateway fd02::1


    Die Schreibweise :: ist eine Abkürzung für "restliche Viererblöcke mit Nullen auffüllen". fd01::3 heißt fd01, dann nur Nullen und dahinter noch ein Block mit 3, also fd01:0000:0000:0000:0000:0000:0000:0003, was man auch als fd01:0:0:0:0:0:0:3 schreiben kann.


    Server auf dem PC auf der WAN-Seite starten, damit die Firewall im Router nicht dazwischenfunkt. Es sollte reichen, auf dem Client als Serveradresse fd01::3 anzugeben. iPerf weiß selbst, dass das eine IPv6 Adresse ist. Nach dem Test nicht vergessen, die statische IPv6 Konfiguration der PCs wieder auszuschalten.

  • So hatte ich es prinzipiell gestern schon vermutet, aber ich konnte die Gegenseite nicht mal anpingen. Das lag vermutlich daran, dass ich folgende Adressen verwendet habe: ::1:0:0:0:1 und ::1:0:0:0:2 usw.


    Ich habe das jetzt mit deinen Adressen probiert und komme mit ping6 vom Client (LAN) zum Server-PC (WAN) durch.

    Code
    1. ping6 fd01::3
    2. PING fd01::3(fd01::3) 56 data bytes
    3. 64 bytes from fd01::3: icmp_seq=1 ttl=63 time=0.647 ms
    4. 64 bytes from fd01::3: icmp_seq=2 ttl=63 time=0.372 ms
    5. 64 bytes from fd01::3: icmp_seq=3 ttl=63 time=0.358 ms
    6. ^C
    7. --- fd01::3 ping statistics ---
    8. 3 packets transmitted, 3 received, 0% packet loss, time 2052ms
    9. rtt min/avg/max/mdev = 0.358/0.459/0.647/0.133 ms


    iperf meldet aber "Broken Pipe".


    Code
    1. ~ $ iperf -c fd01::3
    2. write1 failed: Broken pipe
    3. ------------------------------------------------------------
    4. Client connecting to fd01::3, TCP port 5001
    5. TCP window size: 16.0 KByte (default)
    6. ------------------------------------------------------------
    7. [ 3] local 0.0.0.0 port 0 connected with :: port 5001
    8. [ ID] Interval Transfer Bandwidth
    9. [ 3] 0.0-10.0 sec 16384 PBytes 14756 Pbits/sec



    Ich habe gleichzeitig auch ipv4 statisch konfiguriert und ich kann mit der gleichen Verbindung iperf erfolgreich testen. Also grundsätzlich funktioniert es, nur nicht mit ipv6.

Erstelle ein Benutzerkonto oder melde dich an um zu kommentieren

Du musst ein Benutzerkonto haben um einen Kommentar hinterlassen zu können

Benutzerkonto erstellen
Neues Benutzerkonto für unsere Community erstellen. Geht einfach!
Neues Benutzerkonto erstellen
Anmelden
Du hast bereits ein Benutzerkonto? Melde dich hier an.
Jetzt anmelden