Beiträge von fugu2.0

    So, ich wollte mich nochmal melden, wenn die Umstellung erfolgt ist. Das ist die Woche geschehen, und ging schnell und unkompliziert. Die UDM hat nach der Verbindung mit dem NT auch fein eine IP bezogen und mit den Einstellungen von der_user bekomme ich jetzt auch auf meinen Clients eine IPv6. Der Test unter https://ipv6-test.com/ verläuft auch erfolgreich. Den Zugriff von außen habe ich soweit auch hinbekommen.


    Danke nochmal an alle, die hier kommentiert und weitergeholfen haben :)

    Der DG-Router muss ein Präfix kürzer als /64 bekommen (normalerweise bei der DG ein /56, also 8 Bit für deine freie Verwendung).

    Ich denke das bekommt er. In der Config kann ich folgendes sehen: Delegated Prefix: .... /56


    Der DG-Router muss Prefix-Delegation beherrschen und die muss auch konfiguriert sein.

    Das ist der Punkt, den ich bis jetzt noch nicht gefunden habe.

    Besonders die Einstellungen im DG-Router werden nicht einfach sein. Wir hatten hier schon einen ausgedehnten Kampf mit der Firewall dieses Routers. Zu der Problemstellung kommt jetzt noch Prefix-Delegation für den nachgelagerten Router. Leider gibt es zu diesem Router keine nennenswerte Dokumentation und die meisten hier haben andere Router.

    Wäre es dann hier ein Ansatz, den DG Router komplett aus der Kette zu entfernen und die UDM direkt an den NT zu klemmen? Diese scheint ja ebenfalls Prefix Delegation zu beherrschen.

    wow, danke schonmal für eure schnellen Antworten.


    Zitat

    Gut ist es, wenn Du mit einem an den Basic Router verbundenes WLAN Device (Tablet, Handy,...) dir die zugewiesenen Adressen anzeigen lässt.

    Nach deinen Schilderungen vermute ich, das die Geräte keine IPv6 Adresse vom Basic Router erhalten. Dies sollte jedoch der Fall sein. Hast Du eine Möglichkeit das zu prüfen?

    Wenn ich mich mit meinem Endgerät direkt mit dem DG Router verbinde, bekomme ich eine IPv6 zugewiesen. Diese sehe ich dann auch an in der Adminoberfläche des DG Routers :thumbup:


    Und da gibt es auch Prefix Delegation?

    Diese Option habe ich im DG Router nicht gefunden. Sollte es sie geben ist sie jedenfalls nicht mit Prefix Delegation o.ä. gelabelt.

    Hmm. Ob das richtig ist? Die UDM braucht ja am Ende nur ein /64 Prefix vom Basic Router, und muss ihrerseits kein Prefix Delegaton beherrschen.

    Ob das richtig ist, weiß ich leider auch nicht. Deswegen suche ich ja hier Hilfe :)

    Sind das ULA Adressen? Fangen die mit fd00 oder sowas ähnlichem an?

    Die von der UDM vergebenen Adressen beginnen mit fe80:


    Kann die UDM mehrere virtuelle Verbindungen für VLAN aufbauen? Weil sonst wird das Festnetz Telefon nicht funktionieren.

    Ich kann bei der Konfiguration der WAN-Schnittstelle eine VLAN-ID angeben. Allerdings nur eine. Zum Thema Telefon habe ich auch noch eine Frage, die ich alllerdings nachgelagert stellen würde. Wichtig ist zunächst, dass die IPv6-Kette läuft und der Zugriff von außen klappt.

    Hallo zusammen,


    Ich habe mich die letzten Tage schon ein bisschen bei euch im Forum umgeschaut um Lösungen für mein Problem zu finden, aber so ganz zum Erfolg hat es noch nicht geführt. Daher habe ich mich angemeldet und formuliere mein Problem in der Hoffnung, dass ihr mir weiter helfen könnt.


    Kurzfassung:

    Ziel: Zugriff von außen auf einen Server in meinem lokalen Netzwerk, zunächst über IPv6

    Probleme:

    • ipv6-test.com sagt mir, dass IPv6 nicht unterstützt wird
    • in der Adminoberfläche des DG Basic Routers bekomme ich allerdings IPv6 -Infos angezeigt.
    • Meine UDM Pro, die mit dem DG Router verbunden ist, bekommt von diesem keine IPv6 zugewiesen, obwohl DHCP für IPv6 aktiv ist.


    Ausführliche Fassung:


    Wir haben seit gut anderthalb Wochen einen Anschluss der Deutschen Glasfaser. Der Anschluss wurde aktiviert und surfen funktioniert soweit auch. Was allerdings nicht funktioniert ist der Zugriff von außen auf einen lokalen Server in meinem Netzwerk. Dass das über IPv4 nicht ohne weiteres funktioniert habe ich schon erwartet (Stichwort VPS und Tunnel), daher war mein Ansatz es erstmal über IPv6 zu probieren. Die DG stellt meinem Router ja eine IPv6 zur Verfügung also war ich der Meinung, dass das schon irgendwie funktionieren sollte, aber Pustekuchen.


    Mein Setup sieht wie folgt aus:




    In den Einstellungen des Basic Routers sehe ich eine zugewiesene IPv6. DHCP für IPv6 ist ebenfalls aktiviert. In der UDM Pro habe ich für den WAN-Port DHCPv6 mit Prefix Delegation Size 56 aktiviert. Für die LAN-Ports der UDM habe ich die Prefix Delegation, sowie Router Advertisement aktiviert. Das Problem ist, dass die UDM Pro scheinbar keine IPv6 vom Basic Router bekommt. Jedenfalls sehe ich diese nicht in der Adminoberfläche des Basic Routers und auch nicht in den Einstellungen der UDM Pro. Die UDM verteilt allerdings IPv6-Adressen an die internen Clients und ich kann auch vom PC auf den Server über IPv6 zugreifen.


    Was ich zudem merkwürdig finde: Der Test unter ipv6-test.com sagt mir, dass IPv6 nicht unterstützt wird, obwohl ja mein DG Router eine IPv6 zugewiesen bekommen hat?!

    Ich habe auch einen Trace auf die IPv6 des Basic Routers gemacht; das Ergebnis sieht wie folgt aus:



    Ich habe auch versucht, die UDM Pro direkt an den NT zu hängen, habe da aber keine IP zugewiesen bekommen. Das scheint auch korrekt zu sein, weil mein Anschluss nicht für einen kundeneigenen Router konfiguriert ist, soviel habe ich bei meinen Recherchen hier im Forum bereits lernen können.


    Meine Frage ist jetzt, wie komme ich am einfachsten über IPv6 ins Netz und von dort aus auch wieder auf meinen lokalen Server? Ist das Problem hier der DG Router, der der UDM keine IPv6 gibt oder liegt das Problem noch auf einer ganz anderen Ebene? Wäre es empfehlenswert den DG Router ganz aus der Kette zu entfernen und auf kundeneigenen Router umstellen zu lassen?


    Ich hoffe meine Formulierungen waren nicht zu wirr und mein Problem ist klar geworden. Danke schon mal für eure Hilfe.