Kundenservice Deutsche Glasfaser

  • Kundendienst ist gut wenn er mir dabei hilft zu bekommen was ich will und worauf ich sowieso Anspruch habe, nicht wenn er meint mich belehren oder mir anderweitig "helfen" zu sollen, dass ich doch einfach was anderes tun soll.

    Solange es nur darum geht, das zu bekommen, worauf du Anspruch hast, ist das ok. Aber wenn du dich beim Support beklagst, dass du deine Dachpfannen nicht aufhängen kannst, und der stellt fest, dass du noch nicht mal ein Fundament für ein Haus gegossen hast, was soll er dann machen? Da bleibt dann nur ein "belehren" und "was anderes tun". Ungefähr so stellt sich das in diesem Fall dar.

  • Hallo nochmal,


    vielen Dank für die zahlreichen Rückmeldungen.

    Zunächst einmal möchte ich alfalfa und frank_m nochmal ausdrücklich Recht geben. Ich bin selbst schuld, wenn ich die Topologie meines Netzwerkes entsprechend kompliziert gestalte. (Dafür habe ich schon so meine Gründe)

    Damit ich allerdings der Lösung des Problems näher kommen kann ist von der Deutschen Glasfaser auch ein wenig Kooperation zu erwarten. Wenn man bedenkt, dass es hier letztendlich um die Schnittstelle zwischen deren und meinem Netz geht, dann erwartet man wenigstens eine Rückmeldung oder eine Stellungnahme des DG Supports dazu. Die DG könnte sich darin letztendlich auch weigern mir die Informationen zur korrekten Schnittstellenkonfiguration zu übermitteln. Jedoch habe ich bisher keinerlei Rückmeldung erhalten, wodurch sich die DG aus meiner Sicht "tot" stellt. Und mal ganz nebenbei: Der Beschwerde an die Geschäftleitung (Brief mit Rückschein) war auch noch ein Änderungsformular für den Vertrag inklusive einer zusätzlichen Vollmacht beigelegt. Dafür habe ich ebenfalls um eine schriftliche Rückmeldung binnen besagten 2 Wochen gebeten, welche bis jetzt noch nicht bei mir eingegangen ist. Daher hat meiner Ansicht nach Schmu mit seinen bisherigen Beiträgen in diesem Thread genau das richtige zum Ausdruck gebracht.


    Nun aber wieder zurück zur Problemlösung:

    Nach der Anweisung durch alfalfa habe ich einen IPv6 tcpdump auf der WAN Schnittstelle der OPNsense durchgeführt und währenddessen den DHCPv6 Client (OPNsense WAN) erneuern lassen. Das Ergebnis befindet sich als Screenshot und mit der Originaldatei im Anhang dieses Posts.

    Hinweis: Da die Dateiendung ".cap" (Wireshark Mitschnitt Format) beim Upload nicht akzeptiert wurde habe ich die Datei provisorisch in .txt umbenannt. Bitte vor dem Öffnen der Datei wieder ändern.

    Analyse:

    Es ist zu erkennen, dass in der Router Advertisement (ICMPv6 Nachricht) lediglich die physische Adresse des default Gateway der DG enthalten ist. (genau, wie bereits durch frank_m beschrieben) Außerdem ist in der selben Nachricht auch noch eine MTU von 1500 angegeben. (fragmentiert wird ja nicht mehr) Wenn ihr euch nochmal die Routing Tabelle der OPNsense zu Gemüte führt könnt ihr feststellen, dass bei der IPv6 default Route zum upstream Gateway lediglich die minimale MTU von 1280 gesetzt wurde. Warum das so ist weiß ich nicht. Daher stellt sich mir nun die Frage: Warum übernimmt die OPNsense nicht die richtige MTU?

    Weitere Fragen:

    Edit: Woher bekommt die OPNsense denn die IPv6 Adresse des default Gateway, wenn nicht aus dem RA? Bzw. wo könnte der Fehler demnach liegen, dass die IPv6 default Route nicht richtig konfiguriert wird? Welche Versuche könnte ich als nächstes ausprobieren? Oder fällt euch am RA noch etwas fehlerhaftes auf?


    Vielen Dank für eure Hilfe,


    MFG ChrTopf

  • Ja, bis auf die unterschiedlichen Adressen sieht das exakt so aus, wie bei mir.


    Ich bin bei alfalfa: Das Router Advertisement wird gar nicht ausgewertet. Weder die Adresse noch die MTU der Route passen. Möglicherweise sind das Überbleibsel einer vorherigen statischen Konfiguration? Auf jeden Fall solltest du bei der Behandlung und Auswertung der RAs ansetzen.

  • Moin,


    erster Post hier, vielleicht hilf er ja. Habe selber OPNsense an einem DG Anschluss laufen.


    Bei den DHCPv6 Client Optionen ist weder Send IPv6 prefix hint noch Use IPv4 connectivity angewählt.

    Zudem hat bei mir ein Reboot und Geduld geholfen um die "kaputten" Routen weg zu bekommen.


    Grüße

    ATR



  • atari: Musstest du was besonderes einstellen, damit Router Advertisements akzeptiert werden?

    Nein nicht das ich wüsste. Habe auf einem LAN Interface unter Track IPv6 Interface nur eine Prefix ID eingestellt und Allow manual adjustment of DHCPv6 and Router Advertisements nicht angewählt. Adressen werden verteilt und ich komme aus dem Netz rauf via IPv6 Raus und rein.

  • Beitrag von atari ()

    Dieser Beitrag wurde vom Autor gelöscht ().
  • Hallo nochmal,


    die IPv6 Konfiguration auf meiner OPNsense funktioniert jetzt wieder. :love: Nachdem ich in ein paar weiteren Foren unterwegs war habe ich nochmal die Firmware der OPNsense aktualisiert, da die fehlende Auswertung des RA schon sehr verdächtig nach einem Softwarefehler klang. Und das war es auch! Kaum war das Update durch und die OPNsense wieder online, hat die IPv6 Konnektivität mit der bisherigen Konfiguration ohne zusätzliche Änderungen vorzunehmen wieder geklappt. (Dark Mode der OPNsense ist jetzt auch aktiv 8))

    Mir ist es ehrlich gesagt sehr peinlich, dass ich nicht schon früher ein weiteres update durchgeführt habe. frank_m  alfalfa hatten in diesem Fall bezüglich meiner Inkompetenz recht. :S Ich bereue jedoch die Beschwerde an die Geschäftsleitung der Deutschen Glasfaser nicht, da der Support meiner Ansicht nach auf jeden Fall noch verbesserungswürdig ist.


    atari Vielen Dank für deinen zusätzlichen Tipp. Die Änderung dieser Einstellungen hat bei mir zu keinem unterschiedlichen Ergebnis geführt, als mein Problem noch bestand.


    Großer Dank geht an der Stelle nochmal an alfalfa und frank_m, die trotz meiner Inkompetenz stand gehalten und mir weiterhin geholfen haben! :thumbup:

    In den nächsten Tagen werde ich hier noch meine finale Konfiguration von OPNsense und USG posten, sobald ich auch die LAN Seite zum Laufen gebracht habe.


    MFG ChrTopf

  • Und eine Frage nebenbei: Wäre es nicht eine Idee deine ganzen Server-Sachen mal in ein ordentliches RZ zu bringen? Beispielsweise bietet Hetzner ganze Server ja für einen sehr überschaubaren Betrag an.

  • Du findest dieses Forum hier toll und möchtest es unterstützen? Großartig! Hier zeigen wir dir eine Möglichkeit, wie du uns supporten kannst. Es kostet dich keinen Cent mehr und das Forum bleibt hiermit weiter werbefrei.

    Amazon Link

    Nutze diesen Button um bei Amazon einzukaufen. Das kostet dich keinen Cent mehr, jedoch bekommen wir eine kleine Provision.
    Bei Amazon einkaufen und das GF unterstützen
    Mehr Infos gibt es in diesem Thread
  • Hallo allerseits,


    wie versprochen poste ich hiermit die finale und getestete Konfiguration, mit der IPv6 funktioniert.


    Was in der zwischenzeit geschah

    Zunächst wollte ich mein Netzwerk-Setup ohne eine Veränderung in der Hardware-Topologie zum laufen bringen. Leider habe ich nach ein paar weiteren vergeblich aufgewendeten Stunden herausgefunden, dass der USG nicht mehr in der Lage war IPv6 Packete vom LAN weiter zu routen, obwohl alle IPv6 Routen des USG richtig konfiguriert waren. Ich konnte zwar vom USG (über die OPNsense) erfolgreich IPv6 adressen im Internet anpingen, jedoch hat das von den Clients im LAN nicht geklappt. Dieses Verhalten ist bereits vor 4 Wochen aufgetreten und es ist höchstwahrscheinlich ein weiterer Softwarefehler des USG. (LAN war auf SLAAC mit Präfix 1 konfiguriert und RAs haben auch gepasst) Um nicht noch mehr Zeit zu verlieren und die Konfiguration so simpel wie möglich zu halten, habe ich also den USG aus der Topologie entfernt. Aktuell habe ich nur noch die OPNsense Firewall in Benutzung, die IPv6 deutlich besser unterstützt, als der USG. Die OPNsense bietet fast die selben Funktionen, wie der USG, verlangt im Gegenzug aber einen etwas höheren Konfigurationsaufwand. Funktionen, die ich bisher sehr gerne genutzt habe sind z.B. DPI und Fallback WAN. Beides ist ebenfalls mit der OPNsense möglich, sofern die Hardware passt.


    Finale Konfiguration

    Topologie: DG Medienkonverter (NT) <---> OPNsense Firewall <---> Switch/Heimnetzwerk

    IPv6 WAN Schnittstelle der OPNsense

    DHCPv6 mit /56er Prefix (das ist eigentlich schon alles)

    -> siehe Screenshots

    IPv6 LAN Schnittstelle der OPNsense

    IPv6 Configuration: Track (WAN) interface

    IPv6 Prefix ID: 0x0

    Manual configuration: Nur Haken setzen, wenn man seinen eigenen DHCPv6 betreiben und oder die Router Advertisements (RAs) verändern möchte. Wenn z.B. ein eigener DNS server (z.B. Pi-Hole) über IPv6 den LAN Clients zur Verfügrung gestellt werden soll, dann muss man die RAs separat konfigurieren und dort die IPv6 Adresse des DNS servers eintragen.

    -> siehe Screenshots

    Optional: RAs konfigurieren

    Router Advertisments: Stateless

    -> Stateless DHCPv6 und SLAAC für die automatische Konfiguration der IPv6 Clients im LAN

    IPv6 link-local Adresse meines PI-Hole DNS servers ebenfalls eingetragen

    -> siehe Screenshots


    Die obige Konfiguration sollte ausreichen, um die IPv6 Konnektivität einer OPNsense Firewall mit einem Anschluss der Deutschen Glasfaser herzustellen. (Modell des NT: Nokia G-0110G-P)

    Generell bin ich offen für weitere Fragen bezüglich meiner aktuellen Konfiguration falls obige Informationen nicht ausreichen sollten.


    Fazit

    • Der Unifi Security Gateway 3P (USG) ist meiner Ansicht nach nicht für eine reibunglose IPv6 Funktionalität geeignet. Wer also auf IPv6 angewiesen ist, um seine Dienste zu hosten, sollte sich lieber einer OPNsense Firewall oder einer herkömmlichen FritzBox! bedienen.
    • Der Grund für die meisten IPv6 Probleme der letzten Zeit war der USG und nicht die Deutsche Glasfaser.
    • Der Kundenservice der Deutschen Glasfaser ist noch verbesserungswürdig. Zwar sind andere ISPs, laut vorherigen Posts in diesem Thread, scheinbar auch nicht viel besser. Doch zumindest an der Reaktionsfähigkeit der DG muss noch gearbeitet werden. Das geht deutlich zu langsam voran!

    Vielen Dank nochmal an alle, die mir bisher geholfen haben und gute Nerven an diejenigen, die weiterhin auf den DG Support warten müssen!


    MFG ChrTopf


    PS: Jusch Guter Vorschlag! Darüber habe ich bereits nachgedacht. Es wäre allerdings unvorteilhaft alle meine Dienste über einen Cloud-Anbieter zu hosten, da diese in meinem Lokalen Netz laufen müssen.

Erstelle ein Benutzerkonto oder melde dich an um zu kommentieren

Du musst ein Benutzerkonto haben um einen Kommentar hinterlassen zu können

Benutzerkonto erstellen
Neues Benutzerkonto für unsere Community erstellen. Geht einfach!
Neues Benutzerkonto erstellen
Anmelden
Du hast bereits ein Benutzerkonto? Melde dich hier an.
Jetzt anmelden